Category Archives: FAQs

Showing 9 posts of 49 posts found.
FAQs

Is it normal for the LED to be off during operation of the SQ-N10?

Q. On the SQ-N100 the volume control had a LED inside the volume control that always showed you where the volume was set. With the SQ-N10 when the unit is powering up, the LED blinks and then shuts off when the unit is powered up. The LED also blinks when you hit mute. Is the LED supposed to be on / illuminated in normal operation? A. It is MUTE operation at the first 30 seconds when the unit is powering up, during MUTE operation, LED blinks. After 30 seconds, LED shuts off and the unit works normal. So in MUTE operation the LED blinks, while in normal operation LED shuts off.

Continue reading.

Luxman L-505uX rear view
FAQs

Are the pre outs on the Luxman L-505uX always hot or do they only turn on when the separate function is engaged?

Are the pre outs on the L-505uX always hot or do they only turn on when the separate function is engaged? The reason I’m asking is I have a prospective client who is interested in the 505ux and wants to use his subwoofer with it. If the output is not always active, I assume I can split the signal with a Y adapter and send the signal to both the sub and the main in.

Continue reading.

FAQs

Eclipse TD-M1 Firmware Update Failed/Hard Reset

I tried to do the firmware update (to 1.10 from 1.0). Although the file downloaded properly the eclipse said the file was invalid. However it will not leave the mode it was in after rebooting; the white indicator is flashing and I cannot connect to it over bonjour. I am reluctant to turn off the power. Can you suggest a way to salvage this unit?

Continue reading.